Portrait Pro Forums

Full Version: Cannot activate PPS 10.6 on the Windows 7 x64 with 16GB memory
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
The following is a summary from the four tickets I submitted through the support channel. So far only one has been answered and the support person asked me to check whether my RAW files were supported (very rudimentary help -- of course they are supported).

========================================================
Based on the recommendations from users on the dpreview.com forum, I purchased Portrait Professional Studio 10.6 two days ago.

My system is based on Intel i7-870 with 16GB memory running the Windows 7 Ultimate 64-bit. The video card is an AMD Radeon HD6850 with 1GB memory.

When editing TIFF, JPEG and RAW files from my 5D Mark II, I got out of memory messages very often and the program crashed or was not responding.

Thinking it was the problem with the environment, I restarted the computer and tried to open a 5D Mark II RAW file. The program said it was out of memory. The image file was too big.

I added the CR2 file to the batch file list and opened it. After some editing, the program tried to render the final image and it threw up the out of memory message again and said the image file was too big. The process was never larger than 1GB. Why is the program not able use even the available memory? This is a serious bug!

There was no way to try the 64-bit version and it does not justify the 2X price either. I am using Capture One Professional 6.2 for my RAW processing and have just upgraded to CS5 from CS4. All three programs come with 32-bit and 64-bit versions with the same price.

In order to determine the cause, I installed Portrait Pro Studio 10.6 on my laptop with 4GB memory which is also running Windows 7 64-bit. Everything seemed to work perfectly on the laptop but this is not the machine I am using for the photo processing.

There are no out of memory messages issued on the 4GB laptop. When it is running on my desktop computer with 16GB memory and 64-bit Windows 7, the out of memory messages are issued. But it works sometimes. It is quite unpredictable and frustrating.

The problem could be caused by that Portrait Pro Studio is confused by the amount of memory in the system and its 32-bit variables may have overflowed when the system memory exceeds 4GB, the largest number that can be held in a 32-bit unsigned integer.

This problem appears to have nothing to do with the size of the image files as the same image files work under 4GB memory but not under 16GB. On the 16GB machine, the image (JPEG, TIFF or CR2) files can fail to open with the out of memory message yet on the 4GB laptop, there was never an issue with any image files from the 5D or 5D Mark II to be opened.

Things got worse today. In order to determine whether my 64-bit Windows 7 with 16GB memory is having any environmental issues, I installed the Windows 7 x64 Ultimate on a second partition.

Next I installed Portrait Professional Studio 10.6 and tried to activate it with the token I received after the purchase, PLM-nnn-nnn-nnn-nnn. The installer said the token is already used and the activation failed.

I thought it was because PPS was already activated on my laptop and on the first partition of my desktop so I removed them with complete uninstall.

I tried again on the newly installed Windows 7 partition and got the same message that the token was already used.

Next I tried reinstalling PPS 10.6 on the first partition of my desktop with 16GB memory and it failed to activate with same message that the key/token was already used.

Next I tried reinstalling PPS 10.6 on my laptop with 4GB memory. It was able to activate it. It looks like now the installer/activator is also broken on 16GB machine.

At this point, I have asked for a refund unless there is a version of PPS that works on my Windows 7 x64 system with 16GB memory for the price I have paid.

Has anyone seen this type of memory related problems on the PP Studio?

With kind regards,

Nelson Chen