• ¡Welcome to the PortraitPro Forum!
  • Portrait Professional is now PortraitPro!
Hello There, Guest! Login Register

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Portrait Professional LightRoom plug does not work
I am trying to use Portrait Professional studio as a LightRoom plug in but get an error when I import the file back to light room. The error I get in LightRoom says that there was an error working with the photo. "LightRoom has encountered problems reading this photo. You will not be able to make adjustments to the photo". I tried saving the file as a tiff, jpg and png but none will work. I tried upgrading LightRoom from 4.3 to 4.4 and that did not help.

I can open the file end edit in Portrait Professional stand alone and reimport. I can go from light room to Elements to Portrait Professional and then back through Elements to LightRoom and the file is good.

I tried the free support but I guess you get what you pay for because support is pretty much worthless. Support only says “We have had another customer report the same issue, the cause of this issue does not lie with Portrait Professional.” and then gives me a link to some forum posts about corrupt photos in LightRoom. I have over 24,000 photos in LightRoom and the only ones with a problem are the one imported through the Portrait Professional plugin. I have other application that I use as a plugin from light room that work fine. Does not sound like support has any interested in finding out why the software does not function correctly.

Does anyone have any suggestions?
Hi G-Four,

If you can pass on your ticket number to me, I'd be glad to take a look at the issue for you.

Anthropics Technology Ltd.
(04-10-2013, 03:59 PM)Arjun Wrote: Hi G-Four,

If you can pass on your ticket number to me, I'd be glad to take a look at the issue for you.


Sent PM
(04-10-2013, 04:53 PM)G-Four Wrote:
(04-10-2013, 03:59 PM)Arjun Wrote: Hi G-Four,

If you can pass on your ticket number to me, I'd be glad to take a look at the issue for you.


Sent PM

Hi G-Four,

I've sent you a PM, but if anyone else is affected by this issue, we're currently verifying the fix and will be releasing it via an update very soon.

If anyone else is affected, we do apologise for the inconvenience and the issue will be fixed very soon.

Anthropics Technology Ltd.
Hi - This is exactly the same trouble that I'm experiencing with Lightroom 3.6 and Portrait Professional 11.2.10 (downloaded today in hopes of a fix). The last two updates had the same trouble as well.

I turned in a support request ticket yesterday but haven't heard back regarding it. I'm not sure what version I originally purchased, but that worked on the same system and with the same version of Lightroom as I now have.

I'm editing on a dual Xenon processor system running Win XP Pro.

Any help would be greatly appreciated.

Update to previous post: Unlike the original poster in this thread, I cannot open in lightroom a tif or jpg photo that has been edited in Portrait Professional stand alone version. -Stephen
It looks like the folks behind Portrait Professional Pro are not going to configure it as a full plugin for Lightroom. I've done a fair amount of playing with it since I brought my computer up to Windows 7 Pro. While tech support was very quick getting my PPP license to me, their answer to my suggestion that they configure it to work as a plugin in Lightroom was met with a curt answer: It has to be used as stand-alone.
The biggest problem I was experiencing on my new system was that by calling up PPP from Lightroom 5 for editing, I could make the edits just fine. But when I clicked on the button to return to Lightroom the edits did not follow in the stacked .tif image; they were gone. As I've tried to figure this out I have come up with two methods to use PPP in Lightroom 5 - neither of which are graceful.
The first is to open up PPP as a standalone editor and go into the settings and uncheck the 'Auto Plug-in Mode' (it's on the Plug-in tab of Settings). Doing this will still allow you to edit in PPP from Lightroom, but you will also have the Save and Save As commands under the File menu of the program to use. Workflow would look like this:
1. After making your Lighroom edits, right-click on your photo and select the 'Edit in PPP' option.
2. Once the new file opens in PPP make your edits
3. Select the Save As menu item under the File drop down list and name your file to match the original filename (except for the file extension).

The problem with this method is two-fold:
1. PPP will not automatically name your edited PPP file to match the original file's filename. (It will name it 'untitled'.)
2. You will have to import the new saved file into Lightroom which means it will no longer be associated with the original imported collection that you are working with.

The second method is a bit better and requires that the 'Auto Plug-in Mode' option in the Plug-in Tab of the Settings menu in PPP be checked. (You can only change PPP settings when running PPP as a stand alone editor.)

1. Open Lightroom and edit your photo
2. Right-click on your image and select 'Edit in PPP'
3. Perform your editing of the new image in PPP
4. Click on the 'Return from Plugin' Buttom.

If you selected the stacking option in Lightroom you should see an original RAW image file (if you are shooting RAW) and a second image stacked with it with the appropriate file extension for your PPP file. (In my case it would be a .tif) The two images will be identical - your PPP file won't have the edits in it and if you've rated your files in Lightroom you might not even see your new PPP file at all if you are filtering by a higher than 0 rating. However, the file did get written to the directory of the collection that your original file is in and it does have the PPP edits.

To see the file, first lower your rating filtering down to 0. Second, in the Library pane of Lightroom, click on another collection. Then click back on the collection that you are working with. The file will now be visible for further editing and finishing in Lightroom. Note that the new file's name will probably be 'untitled'.tif. Apparently Portrait Professional Pro cannot return a file to Lightroom and change only the file extension. This is a BIG BUG in my estimation because once the two photos (original and new PPP files) are unstacked you cannot restack them because they will not be together in the collection and there is no reference to keep them together. So you're off looking for the new 'untitled'.tif file in your collection. A real pain when you are processing 100 photos together (or more).

I hope that helps some others. In Windows XP I do not believe that I had the renaming issue. I am running the 32bit version of PPP 11 and would be interested in knowing if the behavior I describe above occurs in the 64bit version of PPP. It kind of looks to me like the folks behind PPP have not put any development into the program for several years - or at least since I've had it. And their tendency to poo-poo making it a full featured plugin for Lightroom, leads me to think they are not going to. If they have a reason for not making it a Lightroom plugin they are sure not disclosing it to their users. The advertising leads one to think it is a LR plugin. It's only when you purchase it and try to configure it as a plugin that you realize it does not function as advertised. Even so, I've found a method to work with PPP in my workflow that will last until I find another program.

I am using Studio v 11 and also Elements 11 and LR 5. The plug in works fine in PSE but when I try to open and image from LR it says the file is corrupt but I can open PP as a stand a lone and it opens just fine. Any ideas?

Forum Jump:

1 Guest(s)