PortraitPro Forums

Full Version: Not happy at all with activation *^(*&^*
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Nothing but activation problems with Portrait pro body.   Every time you upgrade the bios it need re-activation. Now I cant activate at all.  This is a piss poor activation scheme. Why would you assume that people are not going to update their bios. Completely stupid. Still waiting for response from support ticket. Ready to ditch anthropics just like I have done with other companies with this stupid scheme.
I've had the same problem with PortraitPro Body and SmartPhotoEditor. There is a way around the problem with PP Body -- manual activation that generates a new BIOS signature. Not so with SPE.
I installed all my programs on my MacBook Air and activated them. Every other day the programs keep deactivating, since there are no hardware changes there is no excuse for this crap activating scheme. I creative severals ticket with regard to this going way back but it is clear that Anthropics is not going to fix this problem. BUYER BEWARE!
I see posts going back to 2015 regarding this problem. They obviously have no intention of fixing it. Good Job Anthropics. Piss off you good Customers.
Activation schemes have 2 purposes. To disallow people who have not purchased the product from using it and allow people who have purchased to use it. Please explain to us why people who have purchased this product (like me) can't use it without constant deactivation.