PortraitPro Forums

Full Version: System performance
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I am using PP Studio V10.5 on a Intel Core 2 Quad CPU Q9300 @2.5GHz, 4 GB RAM and 64-bit Windows 7 Ultimate.
It is taking about 20 seconds to process each photo. Is there anyway to speed this up? I tried (trial copy) on a machine with a slightly faster CPU and it performance is the same.
Check what you've got running in the background. Use MSCONFIG > Startup Tab and uncheck items not necessary on startup. Use the Task Manager (Ctrl Alt Del simultaneously) and close running items not needed, stop processes not required. Use Sysinternals SystemSuite to find out what each running process is/does. You can download it from here http://technet.microsoft.com/en-us/sysin...s/bb842062

If that doesn't increase your system performance try adding some more RAM if you've got some/any spare slots.
Thanks, Rosce.
It seems that PP is using only 2 cores peaking 100% only occasionally. Most of the time, it stays below 70%. RAM is not an issue as it stays below 80% utilisation most of the time. I believe stopping resources may not help but will give it a try later. During processing, disk activity is minimal.
Did you get your problem sorted ?
Unfortunately no! I am a bit busy to try this out at the moment. Anyway, how many second does it take to process on your computer? I am using a 12M pixels image. It will be useful if there are some performance statistics to compare.
It takes me about a minute to process one photo (JPEG format, ranging between 1 & 10Mb in size). That's go to whoa ........... all processing actions. I find it will process JPEGs quicker than other formats. I'm only using the Standard version, not the Studio. I have 16GB of RAM, Windows 7 Home Premium x64 bit.
whoa... my goodness. So I better shut up! LOL. But I find 15-20 seconds can become a drag if there are many to be processed.

I looked at the system performance chart (from task manager) and found that the CPU utilisation is not consistently very high. I hope the developer can make it faster in future.
I'm only a "hobbyist" photographer, not a pro. Maybe if my living depended on having to do (process) images swiftly, I'd probably want my workflow to be as fast as possible.
As far as I'm aware, the CPU only kicks in when all the RAM is utilised, so with 16Gb of RAM I hardly ever see any CPU activity.
I also use a RAM saver software which releases RAM automatically. The software can be configured to release RAM every xx minutes (when xx is the user-set time period).
I've used similar software since Windows 3.11 for Workgroups. I've tried running my programmes with the RAM savers turned on and off and, to be honest, you'd hardly notice a difference.
Kinda like Registry cleaners ............ run one and it finds lots of useless entries, run another immediately afterwards and it finds lots more. That's when learning to edit the Registry manually comes in handy. And yes, I always back the Registry up before "tinkering."